SDK breaking lodash on some sites
Incident Report for LogRocket
Postmortem

A bug in our build pipeline caused our SDK to expose an internal library globally. As a result, our subset of the lodash library was bound to window._, overwriting the existing _ global for some customer sites. This meant that some expected library functions were not defined after our script loaded.

Technical Details:

  • A code change imported all of lodash and accessed a method on the import instead of importing just the method.
  • Webpack bundled lodash, including its window._assignment despite the library being used in a module import context.

Remediations:

  • We’ve added additional tests to catch unwanted pollution of the window object by our SDK
  • We’ve added an internal linting rule to avoid full lodash imports
Posted Jul 19, 2021 - 11:57 EDT

Resolved
We received customer reports that our SDK interfered with the popular lodash library, resulting in broken customer sites. We've rolled back to a known functional version of our SDK.

The incident lasted for about an hour and 40 minutes.
Posted Jul 12, 2021 - 10:20 EDT