Dashboard instability and slow performance

Incident Report for LogRocket

Resolved

The performance issue with our API server has been resolved.
Posted Oct 14, 2025 - 11:59 EDT

Identified

We have identified the cause of the issue and are deploying a mitigation.
Posted Oct 14, 2025 - 11:35 EDT

Investigating

We are investigating performance issues with our API server causing dashboard instability. Data collection is not impacted.
Posted Oct 14, 2025 - 10:53 EDT
This incident affected: Dashboard and Alerts.