Performance issues with primary search database
Incident Report for LogRocket
Resolved
We've seen no additional performance degradation after our mitigation work.
Posted Jan 20, 2023 - 09:00 EST
Update
We have completed processing of our primary indexing backlog, session filtering and metrics will be mostly up-to-date. Our secondary processing system is currently processing and includes some metrics, issues and alerting.
Posted Jan 19, 2023 - 10:41 EST
Monitoring
We have identified the cause of the issue, applied a fix and have begun processing the backlog of events.
Posted Jan 19, 2023 - 03:15 EST
Update
We have restored some indexing to the database but are continuing to fully resolve the situation.
Posted Jan 19, 2023 - 00:03 EST
Update
We are continuing to work with our vendor to remedy the situation. Session data collection continues to be unaffected, but secondary indexing that powers search and metrics continues to be delayed.
Posted Jan 18, 2023 - 20:00 EST
Update
We are continuing to work with our vendor to resolve the issue.
Posted Jan 18, 2023 - 15:02 EST
Update
We are continuing to work with our vendor to resolve the issue with ingesting new data.
Posted Jan 18, 2023 - 13:00 EST
Identified
We have identified the issue with our database vendor and are working with them to remedy the situation.
Posted Jan 18, 2023 - 11:24 EST
Investigating
We are currently investigating an issue impacting our primary search database. Searching for sessions, loading metric charts, issues and alerting are all impacted. Session data collection has not been impacted.
Posted Jan 18, 2023 - 10:41 EST
This incident affected: Dashboard, Issues, Metrics, and Alerts.