Dashboard instability

Incident Report for LogRocket

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 02:10 EDT

Identified

We've identified the problem and are rolling out a fix.
Posted Jun 02, 2026 - 01:41 EDT

Investigating

We're investigating slow and failing dashboard queries.
Posted Jun 02, 2026 - 01:23 EDT
This incident affected: Dashboard.