Issues logging into account
Incident Report for LogRocket
Resolved
This incident has been resolved.
Posted 5 months ago. Mar 19, 2019 - 23:28 EDT
Update
We are continuing to investigate this issue.
Posted 5 months ago. Mar 19, 2019 - 20:12 EDT
Investigating
We are currently experiencing issues for some users who are trying to access their accounts
Posted 5 months ago. Mar 19, 2019 - 19:50 EDT
This incident affected: Dashboard.