Billing not accessible
Incident Report for LogRocket
Resolved
This incident has been resolved.
Posted 11 days ago. Jul 10, 2019 - 13:17 EDT
Identified
Our payments provider is experiencing an outage which is affecting the display of billing information in LogRocket.
Posted 11 days ago. Jul 10, 2019 - 12:58 EDT
This incident affected: Dashboard.